const regex = /^(?=.{8}$)(?=.*[a-z])(?=.*[0-9])(?:(?:[a-z]+|[0-9]+)(?:-|$)){3}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.{8}$)(?=.*[a-z])(?=.*[0-9])(?:(?:[a-z]+|[0-9]+)(?:-|$)){3}', 'gm')
const str = `aa-99-99
99-23-bd
02-xx-04
ab-99-cz
sc-xd-49
99-xav-4
48-xyz-09
9-abc-01
xs-899-x
sss-99-x
10-b1-c2
aa-bb-01
10-11-ac
11-11-11
aa-bb-cc
11-bb-cc`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}