# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[A-Z]{3}\s+[-+]?[0-9.]+\s*%//gm;t' <<< "abcd efghMNP 0.40 % ijkl mnopSNP -3.20 % xyz
\"MNP 0.40 %\" or \"SNP -3.20 %\""