re = /[A-Z]{3}\s+[-+]?[0-9.]+\s*%/m
str = 'abcd efghMNP 0.40 % ijkl mnopSNP -3.20 % xyz
"MNP 0.40 %" or "SNP -3.20 %"'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result