package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\+?\d{10,15}$`)
var str = `+1234567890
1234567890
123
1234567890123467`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}