$re = '/^\+?\d{10,15}$/m';
$str = '+1234567890
1234567890
123
1234567890123467';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);