$re = '/\bFat(?:\s+\w+)*?\s*Bike\b/mi';
$str = 'My father\'s fat bike is a fat tyre bike. #FatBike';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);