re = /\bFat(?:\s+\w+)*?\s*Bike\b/mi
str = 'My father\'s fat bike is a fat tyre bike. #FatBike'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end