import re
regex = re.compile(r"(?i)(http|https|ftp|ftps)://\S*\.(exe|hta|htr|scr)(\S*|\b|$)", flags=re.MULTILINE)
test_str = ("https://oedginnrrl.execute-api.us-east-1.amazonaws.com/v1/readstatus?MailingID=112129934&Email=jn47w%40nih.gov\"\n\n"
" \n"
"https://oedginnrrl.execute-api.us-east-1.amazonaws.com/v1/readstatus?MailingID=112131410&Email=james.king%40nih.gov\"\n\n"
"http://list.nih.gov/cgi-bin/wa.exe?SUBED1=PHS-AD-PHARMACISTS&A=1\n\n"
"https://oedginnrrl.execute-api.us-east-1.amazonaws.com/v1/readstatus?MailingID=112130096&Email=jerry.suls%40nih.gov\"\n\n"
"https://web.streamlinevrs.com/pmt_common/d_images/email_186198972.script\n\n"
" \n"
"http://www.scripps.edu/>\n\n"
"https://oedginnrrl.execute-api.us-east-1.amazonaws.com/v1/readstatus?MailingID=112129882&Email=james.welch%40nih.gov\"\n\n\n\n\n\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")