$re = '/{[^}{]*?\[PPD\](?:FV5003|PP2340|AG7698)_[^}{]*},/m';
$str = '{
"valueSource": "opc",
"opcItemPath": "ns\\u003d1;s\\u003d[PPD]FV5003_HOA.State.IO_Open",
"dataType": "Boolean",
"name": "IO_Open",
"tagType": "AtomicTag",
"opcServer": "Ignition OPC UA Server"
},';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);