import Foundation
let pattern = #"{[^}{]*?\[PPD\](?:FV5003|PP2340|AG7698)_[^}{]*},"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
{
"valueSource": "opc",
"opcItemPath": "ns\u003d1;s\u003d[PPD]FV5003_HOA.State.IO_Open",
"dataType": "Boolean",
"name": "IO_Open",
"tagType": "AtomicTag",
"opcServer": "Ignition OPC UA Server"
},
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)