#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(SSESS.*)=(.+?);\s*path"
Local $sString = "{" & @CRLF & _
" server: 'nginx/1.21.0'," & @CRLF & _
" date: 'Mon, 25 Apr 2022 11:34:20 GMT'," & @CRLF & _
" 'content-type': 'text/html; charset=UTF-8'," & @CRLF & _
" 'transfer-encoding': 'chunked'," & @CRLF & _
" 'x-powered-by': 'PHP/7.4.16'," & @CRLF & _
" expires: 'Sun, 19 Nov 1978 05:00:00 GMT'," & @CRLF & _
" 'cache-control': 'no-store, no-cache, must-revalidate, max-stale=0, private, post-check=0, pre-check=0'," & @CRLF & _
" 'x-content-type-options': 'nosniff'," & @CRLF & _
" 'content-security-policy': "frame-ancestors 'self';"," & @CRLF & _
" 'set-cookie': [" & @CRLF & _
" 'SSESS8b04132f4690dc8ceb7837d5134a5519=ZbgVsmpp6DBRWwNCRMm5DTpfEoKffsNM7l8ILoCWkug; path=/; domain=test.net; secure; HttpOnly'," & @CRLF & _
" 'su=1; expires=Thu, 22-Apr-2032 11:34:20 GMT; Max-Age=315360000; path=/; domain=test.net'," & @CRLF & _
" 'lt=deleted; expires=Thu, 01-Jan-1970 00:00:01 GMT; Max-Age=0; path=/; test.net'," & @CRLF & _
" 'dtCookie=v_4_srv_10_sn_6364C36040ADFF47B91A838BB8B2CADD_perc_100000_ol_0_mul_1_app-3Aea7c4b59f27d43eb_1; Path=/; Domain=test.net'," & @CRLF & _
" '870be6fb89fc78ad2ca0eca3828e3019=7055c78f3c2b7311a5c77934caad6939; path=/; HttpOnly; Secure; SameSite=None'" & @CRLF & _
" ]," & @CRLF & _
" 'x-oneagent-js-injection': 'true'," & @CRLF & _
" 'x-ruxit-js-agent': 'true'," & @CRLF & _
" 'server-timing': 'dtSInfo;desc="0", dtRpid;desc="493206686"'," & @CRLF & _
" connection: 'close'" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")