import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(SSESS.*)=(.+?);\\s*path";
final String string = "{\n"
+ " server: 'nginx/1.21.0',\n"
+ " date: 'Mon, 25 Apr 2022 11:34:20 GMT',\n"
+ " 'content-type': 'text/html; charset=UTF-8',\n"
+ " 'transfer-encoding': 'chunked',\n"
+ " 'x-powered-by': 'PHP/7.4.16',\n"
+ " expires: 'Sun, 19 Nov 1978 05:00:00 GMT',\n"
+ " 'cache-control': 'no-store, no-cache, must-revalidate, max-stale=0, private, post-check=0, pre-check=0',\n"
+ " 'x-content-type-options': 'nosniff',\n"
+ " 'content-security-policy': \"frame-ancestors 'self';\",\n"
+ " 'set-cookie': [\n"
+ " 'SSESS8b04132f4690dc8ceb7837d5134a5519=ZbgVsmpp6DBRWwNCRMm5DTpfEoKffsNM7l8ILoCWkug; path=/; domain=test.net; secure; HttpOnly',\n"
+ " 'su=1; expires=Thu, 22-Apr-2032 11:34:20 GMT; Max-Age=315360000; path=/; domain=test.net',\n"
+ " 'lt=deleted; expires=Thu, 01-Jan-1970 00:00:01 GMT; Max-Age=0; path=/; test.net',\n"
+ " 'dtCookie=v_4_srv_10_sn_6364C36040ADFF47B91A838BB8B2CADD_perc_100000_ol_0_mul_1_app-3Aea7c4b59f27d43eb_1; Path=/; Domain=test.net',\n"
+ " '870be6fb89fc78ad2ca0eca3828e3019=7055c78f3c2b7311a5c77934caad6939; path=/; HttpOnly; Secure; SameSite=None'\n"
+ " ],\n"
+ " 'x-oneagent-js-injection': 'true',\n"
+ " 'x-ruxit-js-agent': 'true',\n"
+ " 'server-timing': 'dtSInfo;desc=\"0\", dtRpid;desc=\"493206686\"',\n"
+ " connection: 'close'\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}