$re = '/chrome\D\d{0,}/';
$str = 'chrome
chrome#32
chrome#2
chrome#543
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);