#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\b[a|b]{2}a[a|b]*b[a|b]{4}\b|\b[a|b]ba[a|b][a|b]{2}\b|\bb[a|b]{1}a[a|b]{2}\b"
Local $sString = "aaabaaaa abaaaa baaaa aabaaaa aaaaaaba"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")