re = /\b[a|b]{2}a[a|b]*b[a|b]{4}\b|\b[a|b]ba[a|b][a|b]{2}\b|\bb[a|b]{1}a[a|b]{2}\b/
str = 'aaabaaaa abaaaa baaaa aabaaaa aaaaaaba'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end