#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((8|\+7)[\- ]?)?(\(?\d{3}\)?[\- ]?)?[\d\- ]{7,10}"
Local $sString = "+79261234567" & @CRLF & _
"89261234567" & @CRLF & _
"79261234567" & @CRLF & _
"+7 926 123 45 67" & @CRLF & _
"8(926)123-45-67" & @CRLF & _
"123-45-67" & @CRLF & _
"9261234567" & @CRLF & _
"79261234567" & @CRLF & _
"(495)1234567" & @CRLF & _
"(495) 123 45 67" & @CRLF & _
"89261234567" & @CRLF & _
"8-926-123-45-67" & @CRLF & _
"8 927 1234 234" & @CRLF & _
"8 927 12 12 888" & @CRLF & _
"8 927 12 555 12" & @CRLF & _
"8 927 123 8 123"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")