import re
regex = re.compile(r"((8|\+7)[\- ]?)?(\(?\d{3}\)?[\- ]?)?[\d\- ]{7,10}", flags=re.MULTILINE)
test_str = ("+79261234567\n"
"89261234567\n"
"79261234567\n"
"+7 926 123 45 67\n"
"8(926)123-45-67\n"
"123-45-67\n"
"9261234567\n"
"79261234567\n"
"(495)1234567\n"
"(495) 123 45 67\n"
"89261234567\n"
"8-926-123-45-67\n"
"8 927 1234 234\n"
"8 927 12 12 888\n"
"8 927 12 555 12\n"
"8 927 123 8 123")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")