#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?P<unit_type>S)(?P<unit_size>\d{1,2})(?P<mounting_type>A|P)(?P<cracking_pressure>\d{1,2})(?P<sep_1>-)(?P<unit_series>1X)(?P<sep_2>/|=)(?P<pressure_rating_max>\d{1,3}|)(?P<surface_coating>J3|J5|)(?P<orifice_position>B|)(?P<orifice_diameter>\d{1,2}|)(?P<pipe_port>/2|/12|)(?P<special_version>(.|[0-9])*)$"
Local $sString = "S20P15-1X/" & @CRLF & _
"S30P05-1X/V" & @CRLF & _
"S30P02-1X/V" & @CRLF & _
"S30P15-1X/V" & @CRLF & _
"S30P30-1X/V" & @CRLF & _
"S30P50-1X/V" & @CRLF & _
"S30P00-1X/" & @CRLF & _
"S30P05-1X/" & @CRLF & _
"S30P15-1X/" & @CRLF & _
"S30P30-1X/" & @CRLF & _
"S30P50-1X/" & @CRLF & _
"S10P00-1X/" & @CRLF & _
"S10P05-1X/" & @CRLF & _
"S10P05-1X/V" & @CRLF & _
"S10P15-1X/" & @CRLF & _
"S10P15-1X/V" & @CRLF & _
"S10P30-1X/" & @CRLF & _
"S10P30-1X/V" & @CRLF & _
"S10P50-1X/" & @CRLF & _
"S20P00-1X/" & @CRLF & _
"S20P05-1X/" & @CRLF & _
"S20P05-1X/SO74" & @CRLF & _
"S20P05-1X/V" & @CRLF & _
"S20P05-1X/VSO74" & @CRLF & _
"S20P15-1X/SO74" & @CRLF & _
"S20P15-1X/V" & @CRLF & _
"S20P30-1X/" & @CRLF & _
"S20P30-1X/SO74" & @CRLF & _
"S20P30-1X/V" & @CRLF & _
"S20P30-1X/VSO74" & @CRLF & _
"S20P50-1X/" & @CRLF & _
"S30P05-1X/VSO74" & @CRLF & _
"S30P00-1X/SO74" & @CRLF & _
"S30P15-1X/SO74" & @CRLF & _
"S30P05-1X/SO74" & @CRLF & _
"S25P15-1X/V" & @CRLF & _
"S15P15-1X/V" & @CRLF & _
"S15P15-1X/" & @CRLF & _
"S25P15-1X/" & @CRLF & _
"S10A05-1X/450J3" & @CRLF & _
"S20A05-1X/450J3" & @CRLF & _
"S30P05-1X=V" & @CRLF & _
"S30P50-1X=V" & @CRLF & _
"S10P05-1X=V" & @CRLF & _
"S10P30-1X=V" & @CRLF & _
"S20P05-1X=V" & @CRLF & _
"S15A02-1X/450J3" & @CRLF & _
"S20A02-1X/450J3" & @CRLF & _
"S10A05-1X/450J3/12" & @CRLF & _
"S20A05-1X/450J3B15/12" & @CRLF & _
"S10A15-1X/450J3/12" & @CRLF & _
"S20A30-1X/450J3" & @CRLF & _
"S6A00-1X/450J3" & @CRLF & _
"S6A02-1X/450J3" & @CRLF & _
"S6A05-1X/450J3" & @CRLF & _
"S6A15-1X/450J3" & @CRLF & _
"S6A30-1X/450J3" & @CRLF & _
"S6A50-1X/450J3" & @CRLF & _
"S8A00-1X/450J3" & @CRLF & _
"S8A02-1X/450J3" & @CRLF & _
"S8A05-1X/450J3" & @CRLF & _
"S8A15-1X/450J3" & @CRLF & _
"S8A30-1X/450J3" & @CRLF & _
"S8A50-1X/450J3" & @CRLF & _
"S10A00-1X/450J3" & @CRLF & _
"S10A02-1X/450J3" & @CRLF & _
"S10A02-1X/450J3/12" & @CRLF & _
"S10A15-1X/450J3" & @CRLF & _
"S10A30-1X/450J3" & @CRLF & _
"S10A50-1X/450J3" & @CRLF & _
"S15A00-1X/450J3" & @CRLF & _
"S15A05-1X/450J3B00" & @CRLF & _
"S15A05-1X/450J3" & @CRLF & _
"S15A15-1X/450J3" & @CRLF & _
"S15A30-1X/450J3" & @CRLF & _
"S15A50-1X/450J3" & @CRLF & _
"S20A00-1X/450J3" & @CRLF & _
"S20A02-1X/450J3/12" & @CRLF & _
"S20A05-1X/450J3/12" & @CRLF & _
"S20A15-1X/450J3" & @CRLF & _
"S20A30-1X/450J3/12" & @CRLF & _
"S20A50-1X/450J3" & @CRLF & _
"S25A00-1X/420J3" & @CRLF & _
"S25A02-1X/420J3" & @CRLF & _
"S25A05-1X/420J3" & @CRLF & _
"S25A15-1X/420J3" & @CRLF & _
"S25A30-1X/420J3" & @CRLF & _
"S25A50-1X/420J3" & @CRLF & _
"S25A80-1X/420J3" & @CRLF & _
"S30A00-1X/420J3" & @CRLF & _
"S30A02-1X/420J3" & @CRLF & _
"S30A05-1X/420J3" & @CRLF & _
"S30A15-1X/420J3" & @CRLF & _
"S30A30-1X/420J3" & @CRLF & _
"S30A50-1X/420J3" & @CRLF & _
"S30A80-1X/420J3" & @CRLF & _
"S8A00-1X/450J3/12" & @CRLF & _
"S8A05-1X/450J3/12" & @CRLF & _
"S8A15-1X/450J3/12" & @CRLF & _
"S8A30-1X/450J3/12" & @CRLF & _
"S10A00-1X/450J3/12" & @CRLF & _
"S10A30-1X/450J3/12" & @CRLF & _
"S10A50-1X/450J3/12" & @CRLF & _
"S15A00-1X/450J3/12" & @CRLF & _
"S15A02-1X/450J3/12" & @CRLF & _
"S15A05-1X/450J3/12" & @CRLF & _
"S15A15-1X/450J3/12" & @CRLF & _
"S15A30-1X/450J3/12" & @CRLF & _
"S15A50-1X/450J3/12" & @CRLF & _
"S20A00-1X/450J3/12" & @CRLF & _
"S20A15-1X/450J3/12" & @CRLF & _
"S20A50-1X/450J3/12" & @CRLF & _
"S25A00-1X/420J3/12" & @CRLF & _
"S25A02-1X/420J3/12" & @CRLF & _
"S25A05-1X/420J3/12" & @CRLF & _
"S25A15-1X/420J3/12" & @CRLF & _
"S25A30-1X/420J3/12" & @CRLF & _
"S25A50-1X/420J3/12" & @CRLF & _
"S30A00-1X/420J3/12" & @CRLF & _
"S30A02-1X/420J3/12" & @CRLF & _
"S30A05-1X/420J3/12" & @CRLF & _
"S30A15-1X/420J3/12" & @CRLF & _
"S30A30-1X/420J3/12" & @CRLF & _
"S30A50-1X/420J3/12" & @CRLF & _
"S10A05-1X/450J3B08" & @CRLF & _
"S10A05-1X/450J3B15" & @CRLF & _
"S25A15-1X/420J3B10" & @CRLF & _
"S25A50-1X/420J3B00" & @CRLF & _
"S10A05-1X/450J3B00" & @CRLF & _
"S20A05-1X/450J3B00" & @CRLF & _
"S30A05-1X/420J3B00" & @CRLF & _
"S30A05-1X/420J3B10" & @CRLF & _
"S30A80-1X/420J3B12" & @CRLF & _
"S15A05-1X/450J5/12" & @CRLF & _
"S8A05-1X/450J3B03" & @CRLF & _
"S30A50-1X/420J3B12" & @CRLF & _
"S10A05-1X/450J3B10" & @CRLF & _
"S30A30-1X/420J3B12" & @CRLF & _
"S25A30-1X/420J3B12" & @CRLF & _
"S15A05-1X/450J5" & @CRLF & _
"S15A05-1X/450J5/12=AH" & @CRLF & _
"S8A05-1X/450J3B08" & @CRLF & _
"S10A05-1X=450J3" & @CRLF & _
"S25A00-1X/420J3B10" & @CRLF & _
"S10A05-1X/450J3B12" & @CRLF & _
"S30A05-1X=420J3" & @CRLF & _
"S10A50-1X/450J3/2" & @CRLF & _
"S8A05-1X/450J3B05" & @CRLF & _
"S15A50-1X/450J5" & @CRLF & _
"S10A05-1X/450J3B10/12" & @CRLF & _
"S25A50-1X/420J3B10" & @CRLF & _
"S15A05-1X/450J3/2" & @CRLF & _
"S15A05-1X/450J3B10" & @CRLF & _
"S20A05-1X/450J3B10" & @CRLF & _
"S25A05-1X=420J3/12" & @CRLF & _
"S8A50-1X/450J5" & @CRLF & _
"S8A05-1X/450J3B00" & @CRLF & _
"S15A05-1X=450J3" & @CRLF & _
"S25A05-1X=420J3" & @CRLF & _
"S20A05-1X/450J3B15" & @CRLF & _
"S6A05-1X=450J3" & @CRLF & _
"S15A30-1X/450J3B10" & @CRLF & _
"S20A05-1X/450J5" & @CRLF & _
"S20A30-1X/450J3B15" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")