// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?P<unit_type>S)(?P<unit_size>\d{1,2})(?P<mounting_type>A|P)(?P<cracking_pressure>\d{1,2})(?P<sep_1>-)(?P<unit_series>1X)(?P<sep_2>/|=)(?P<pressure_rating_max>\d{1,3}|)(?P<surface_coating>J3|J5|)(?P<orifice_position>B|)(?P<orifice_diameter>\d{1,2}|)(?P<pipe_port>/2|/12|)(?P<special_version>(.|[0-9])*)$").unwrap();
let string = "S20P15-1X/
S30P05-1X/V
S30P02-1X/V
S30P15-1X/V
S30P30-1X/V
S30P50-1X/V
S30P00-1X/
S30P05-1X/
S30P15-1X/
S30P30-1X/
S30P50-1X/
S10P00-1X/
S10P05-1X/
S10P05-1X/V
S10P15-1X/
S10P15-1X/V
S10P30-1X/
S10P30-1X/V
S10P50-1X/
S20P00-1X/
S20P05-1X/
S20P05-1X/SO74
S20P05-1X/V
S20P05-1X/VSO74
S20P15-1X/SO74
S20P15-1X/V
S20P30-1X/
S20P30-1X/SO74
S20P30-1X/V
S20P30-1X/VSO74
S20P50-1X/
S30P05-1X/VSO74
S30P00-1X/SO74
S30P15-1X/SO74
S30P05-1X/SO74
S25P15-1X/V
S15P15-1X/V
S15P15-1X/
S25P15-1X/
S10A05-1X/450J3
S20A05-1X/450J3
S30P05-1X=V
S30P50-1X=V
S10P05-1X=V
S10P30-1X=V
S20P05-1X=V
S15A02-1X/450J3
S20A02-1X/450J3
S10A05-1X/450J3/12
S20A05-1X/450J3B15/12
S10A15-1X/450J3/12
S20A30-1X/450J3
S6A00-1X/450J3
S6A02-1X/450J3
S6A05-1X/450J3
S6A15-1X/450J3
S6A30-1X/450J3
S6A50-1X/450J3
S8A00-1X/450J3
S8A02-1X/450J3
S8A05-1X/450J3
S8A15-1X/450J3
S8A30-1X/450J3
S8A50-1X/450J3
S10A00-1X/450J3
S10A02-1X/450J3
S10A02-1X/450J3/12
S10A15-1X/450J3
S10A30-1X/450J3
S10A50-1X/450J3
S15A00-1X/450J3
S15A05-1X/450J3B00
S15A05-1X/450J3
S15A15-1X/450J3
S15A30-1X/450J3
S15A50-1X/450J3
S20A00-1X/450J3
S20A02-1X/450J3/12
S20A05-1X/450J3/12
S20A15-1X/450J3
S20A30-1X/450J3/12
S20A50-1X/450J3
S25A00-1X/420J3
S25A02-1X/420J3
S25A05-1X/420J3
S25A15-1X/420J3
S25A30-1X/420J3
S25A50-1X/420J3
S25A80-1X/420J3
S30A00-1X/420J3
S30A02-1X/420J3
S30A05-1X/420J3
S30A15-1X/420J3
S30A30-1X/420J3
S30A50-1X/420J3
S30A80-1X/420J3
S8A00-1X/450J3/12
S8A05-1X/450J3/12
S8A15-1X/450J3/12
S8A30-1X/450J3/12
S10A00-1X/450J3/12
S10A30-1X/450J3/12
S10A50-1X/450J3/12
S15A00-1X/450J3/12
S15A02-1X/450J3/12
S15A05-1X/450J3/12
S15A15-1X/450J3/12
S15A30-1X/450J3/12
S15A50-1X/450J3/12
S20A00-1X/450J3/12
S20A15-1X/450J3/12
S20A50-1X/450J3/12
S25A00-1X/420J3/12
S25A02-1X/420J3/12
S25A05-1X/420J3/12
S25A15-1X/420J3/12
S25A30-1X/420J3/12
S25A50-1X/420J3/12
S30A00-1X/420J3/12
S30A02-1X/420J3/12
S30A05-1X/420J3/12
S30A15-1X/420J3/12
S30A30-1X/420J3/12
S30A50-1X/420J3/12
S10A05-1X/450J3B08
S10A05-1X/450J3B15
S25A15-1X/420J3B10
S25A50-1X/420J3B00
S10A05-1X/450J3B00
S20A05-1X/450J3B00
S30A05-1X/420J3B00
S30A05-1X/420J3B10
S30A80-1X/420J3B12
S15A05-1X/450J5/12
S8A05-1X/450J3B03
S30A50-1X/420J3B12
S10A05-1X/450J3B10
S30A30-1X/420J3B12
S25A30-1X/420J3B12
S15A05-1X/450J5
S15A05-1X/450J5/12=AH
S8A05-1X/450J3B08
S10A05-1X=450J3
S25A00-1X/420J3B10
S10A05-1X/450J3B12
S30A05-1X=420J3
S10A50-1X/450J3/2
S8A05-1X/450J3B05
S15A50-1X/450J5
S10A05-1X/450J3B10/12
S25A50-1X/420J3B10
S15A05-1X/450J3/2
S15A05-1X/450J3B10
S20A05-1X/450J3B10
S25A05-1X=420J3/12
S8A50-1X/450J5
S8A05-1X/450J3B00
S15A05-1X=450J3
S25A05-1X=420J3
S20A05-1X/450J3B15
S6A05-1X=450J3
S15A30-1X/450J3B10
S20A05-1X/450J5
S20A30-1X/450J3B15
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}