import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\S)<\\/[^>]*>\\s*<[^>]*>(\\S)";
final String string = "<Inventory>\n"
+ " <Item>\n"
+ " <Name>Super Mario Bros</Name>\n"
+ " <Count>14</Count>\n"
+ " <Price>29,99</Price>\n"
+ " <Comment>-No Comment-</Comment>\n"
+ " <Artist>N/A</Artist>\n"
+ " <Publisher>Nintendo</Publisher>\n"
+ " <Genre>Video Games</Genre>\n"
+ " <Year>1985</Year>\n"
+ " <ProductID>001</ProductID>\n"
+ " </Item>\n"
+ " <Item>\n"
+ " <Name>The Legend of Zelda</Name>\n"
+ " <Count>12</Count>\n"
+ " <Price>34,99</Price>\n"
+ " <Comment>-No Comment-</Comment>\n"
+ " <Artist>N/A</Artist>\n"
+ " <Publisher>Nintendo</Publisher>\n"
+ " <Genre>Video Games</Genre>\n"
+ " <Year>1986</Year>\n"
+ " <ProductID>002</ProductID>\n"
+ " </Item>\n"
+ "</Inventory>";
final String subst = "$1\",\"$2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}