$re = '/mul\((\d{1,3}),(\d{1,3})\)|do\(\)|don\'t\(\)/m';
$str = 'mul(12,15)do()don\'t()';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);