# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\B@([a-z0-9](?:-(?=[a-z0-9])|[a-z0-9]){0,38}(?<=[a-z0-9]))"
test_str = ("@username\n\n"
"@user in a @user2 pagagraph of @user: text @usern-ame! @inalid- \n\n"
"@d\n\n"
"@12345678912345678912345678911112345678904 \n\n"
"@invalid--username\n\n"
"and @valid-username-: l\n\n"
"@-a\n"
"@-invalid\n"
"@1\n"
"@a\n\n"
"@invalid-\n\n"
"hdj @hfd.com\n\n"
"some @valid-dd username\n\n"
"email@test.com \n\n"
"@validu-sername- but is it worth it?\n\n"
"@johndoe.\n"
"@johndoe-\n"
"@johndoe-a\n\n"
"@fo-o-o-o-o-o-o-o-o-o-o-o-o-o-o-o-o-o-o-o-o-o-o-o-o-o-o-o-o-o-o-o-o-o-o-o-o-o")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.