re = /\B@([a-z0-9](?:-(?=[a-z0-9])|[a-z0-9]){0,38}(?<=[a-z0-9]))/i
str = '@username
@user in a @user2 pagagraph of @user: text @usern-ame! @inalid-
@d
@12345678912345678912345678911112345678904
@invalid--username
and @valid-username-: l
@-a
@-invalid
@1
@a
@invalid-
hdj @hfd.com
some @valid-dd username
email@test.com
@validu-sername- but is it worth it?
@johndoe.
@johndoe-
@johndoe-a
@fo-o-o-o-o-o-o-o-o-o-o-o-o-o-o-o-o-o-o-o-o-o-o-o-o-o-o-o-o-o-o-o-o-o-o-o-o-o'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end