#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b\d{1,2}/\d{1,2}(?:/\d{4}|/\d{2})?"
Local $sString = "String1 = "John Lennon died on 08/12/80"" & @CRLF & _
"String2 = “Labor day is on 1/5"" & @CRLF & _
"String3 = “Wikipedia was launched on 15/1/2001” " & @CRLF & _
"15/1/201" & @CRLF & _
"15/1//201"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")