package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b\d{1,2}/\d{1,2}(?:/\d{4}|/\d{2})?`)
var str = `String1 = "John Lennon died on 08/12/80"
String2 = “Labor day is on 1/5"
String3 = “Wikipedia was launched on 15/1/2001”
15/1/201
15/1//201`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}