import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b\\d{1,2}/\\d{1,2}(?:(?!/))\\b";
final String string = "String1 = \"John Lennon died on 08/12/80\"\n"
+ "String2 = “Labor day is on 1/5\"\n"
+ "String3 = “Wikipedia was launched on 15/1/2001” \n"
+ "15/1/2011\n"
+ "15/1//201";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}