const regex = new RegExp('\\b\\d{1,2}/\\d{1,2}(?:(?!/))\\b', 'gm')
const str = `String1 = "John Lennon died on 08/12/80"
String2 = “Labor day is on 1/5"
String3 = “Wikipedia was launched on 15/1/2001”
15/1/2011
15/1//201`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}