$re = '/\b\d[\d\s]{0,13}\d\b/';
$str = '123456 78910111277 123456 12345617777 123456 78912';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);