import re
regex = re.compile(r"\b\d[\d\s]{0,13}\d\b")
test_str = "123456 78910111277 123456 12345617777 123456 78912"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")