package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<iframe.+?src="https?://www.youtube.com/embed/([a-zA-Z0-9_-]{11})"[^>]+?></iframe>`)
var str = `<iframe width="560" height="315" src="http://www.youtube.com/embed/12345678901" frameborder="0" allowfullscreen></iframe>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}