import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<iframe.+?src=\"https?://www.youtube.com/embed/([a-zA-Z0-9_-]{11})\"[^>]+?></iframe>";
final String string = "<iframe width=\"560\" height=\"315\" src=\"http://www.youtube.com/embed/12345678901\" frameborder=\"0\" allowfullscreen></iframe>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}