using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\{\{([^=]*=.*?)\}\}";
string input = @"{{Character
| Title=Jhiqui
| Image=Jhiqui.png
}}
{{Ala|a;a}}";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}