$re = '/\{\{([^=]*=.*?)\}\}/ms';
$str = '{{Character
| Title=Jhiqui
| Image=Jhiqui.png
}}
{{Ala|a;a}}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);