using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?!Foo\b|bar\b)[A-Za-z]+";
string input = @"Hey, Foo, we can meet at the bar.
Hey, Foobar, we can meet at the bar.
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}