$re = '/\b(?!Foo\b|bar\b)[A-Za-z]+/m';
$str = 'Hey, Foo, we can meet at the bar.
Hey, Foobar, we can meet at the bar.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);