re = /^(?:(?:[!#].*)?\n)+/
str = '
# catch this comment
!mycommand
# catch this comment
#catch this comment too
!mycommand
# catch this comment
!mycommand
!mycommand
some code. match until the previous line
# do not catch this comment
!mycommand
# do not catch this comment'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result