package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:\\.|[^*])*\*((?:\\.|[^*])*)\*`)
var str = `\*jdjdjdfdf*test*dfsdf\*adfasdasdasd*test**test\**sd*`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}