import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(ncc|nx)\\D?(\\d*)";
final String string = "USS Odyssey NCC-71832 test\n"
+ "USS Odyssey NCC71832 test\n"
+ "USS Bradbury NX-72307 test\n"
+ "IKS Somraw test";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}