const regex = /(ncc|nx)\D?(\d*)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(ncc|nx)\\D?(\\d*)', 'gi')
const str = `USS Odyssey NCC-71832 test
USS Odyssey NCC71832 test
USS Bradbury NX-72307 test
IKS Somraw test`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}