#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)\bvar\b(?!->)(?=[^;^{]*(?:[<>!]|==))"
Local $sString = "" & @CRLF & _
"var->var1 = blah; " & @CRLF & _
"var = 8;" & @CRLF & _
"if(var >= 9)" & @CRLF & _
"if(var ->var1 == balh)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")