using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bvar\b(?!->)(?=[^;^{]*(?:[<>!]|==))";
string input = @"
var->var1 = blah;
var = 8;
if(var >= 9)
if(var ->var1 == balh)";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}