$re = '/\bvar\b(?!.*(?<![><=])=(?!=))(?=(?:\s*->\s*\w+)*\s*(?:[<!]|-?>|={2}))/ms';
$str = 'var->var1 = blah;
var = 8;
if(var >= 9)
if(var ->var1 == balh)
if(var->var1 == blah)
var-> var1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);