re = /\bvar\b(?!.*(?<![><=])=(?!=))(?=(?:\s*->\s*\w+)*\s*(?:[<!]|-?>|={2}))/m
str = 'var->var1 = blah;
var = 8;
if(var >= 9)
if(var ->var1 == balh)
if(var->var1 == blah)
var-> var1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end