package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)^(?<title>.+?)\s(?<type>(?:UVHDX|itunes).*)$`)
var str = `Why Him UVHDX or itunes HD via MA`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}