$re = '/^(?<title>.+?)\s(?<type>(?:UVHDX|itunes).*)$/i';
$str = 'Why Him UVHDX or itunes HD via MA';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);