const regex = /[^\\]*\.(\w+)\s/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^\\\\]*\\.(\\w+)\\s', 'gm')
const str = `Symchk result for D:\\pkgshadow\\19H1\\999907\\files.csi\\arm64\\neutral\\fre\\Microsoft-OneCore-VirtualizationBasedSecurity-Package~31bf3856ad364e35~amd64~~10.0.21380.1020.mum is NOTAPPLICABLE`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}