package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)t-(?<new_field_name>\d+$)`)
var str = `id = bdf73ad5-4499-4f70-b7e3-e2c81ae868c3-default-asset-423447
id = bdf73ad5-4499-4f70-b7e3-e2c81ae868c3-default-asset-6672
id = bdf73ad5-4499-4f70-b7e3-e2c81ae868c3-default-asset-4232323
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}