use strict;
my $str = 'id = bdf73ad5-4499-4f70-b7e3-e2c81ae868c3-default-asset-423447
id = bdf73ad5-4499-4f70-b7e3-e2c81ae868c3-default-asset-6672
id = bdf73ad5-4499-4f70-b7e3-e2c81ae868c3-default-asset-4232323
';
my $regex = qr/t-(?<new_field_name>\d+$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}