#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^|\v].*(*SKIP)(*F)|\[\K[^]]+"
Local $sString = "*Intro*" & @CRLF & _
"| [C] – [G] – [Am] – [F] – [Dm] – [G]" & @CRLF & _
"" & @CRLF & _
"*VERSE 1*" & @CRLF & _
"=[C][G][Am]" & @CRLF & _
"=cu{a}nto he esp{e}rado este mo{m}ento" & @CRLF & _
"| [F] – [F] – [Dm] – [F] – [Dm] – [G]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")