$re = '/^[^|\v].*(*SKIP)(*F)|\[\K[^]]+/m';
$str = '*Intro*
| [C] – [G] – [Am] – [F] – [Dm] – [G]
*VERSE 1*
=[C][G][Am]
=cu{a}nto he esp{e}rado este mo{m}ento
| [F] – [F] – [Dm] – [F] – [Dm] – [G]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);